(+84) 463.28.7979

Fix WordPress 2.5 Bugs with 2.5.1 Security Release


Its time to upgrade wordpress again and fix the bugs affecting wordpress 2.5. However, its not optional – its a security release and intended for all wordpress users, particularly those using open registration.

If you need only security fixes, simply download wordpress and replace these corrected copies via FTP
wp-includes/pluggable.php
wp-admin/includes/media.php
wp-admin/media.php

But if you want to grab the 70 other fixes, then you need to upgrade to the full wordpress 2.5.1 that focuses on fixing the most annoying bugs and improving performance.

  • Performance improvements for the Dashboard, Write Post, and Edit Comments pages.
  • Better performance for those who have many categories
  • Media Uploader fixes
  • An upgrade to TinyMCE 3.0.7
  • Widget Administration fixes
  • Various usability improvements
  • Layout fixes for IE

Though WordPress 2.5 has changed by writing habits, yet some veteran wordpress bloggers are still unhappy with WordPress 2.5 and some bugs should be fixed now.

Always remember to back up your database before upgrading, and if your database backup emails are not reaching your inbox, see how to fix the issue and reduce database file size. You can try the InstantUpgrade Plugin for performing automatic wordpress upgrades. Put your blog in Maintenance mode so your visitors see a professional scheduled upgrade message. Some bloggers try faster multiple wordpress upgrades via Shell Access. If you land up with unusual wordpress bugs, then check for uploaded files on your server.

I upgraded easily in minutes and secured my blog. You can do it now too. Note that database upgrade was needed.

Leave a Reply

Your email address will not be published. Required fields are marked *

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>