(+84) 463.28.7979

Plugin Sandboxing in WordPress 2.2 : Safer Activation


Do you fear that a new wordpress plugin you wish to install might crash your wordpress blog? Mark reports that they have finished a powerful feature in WordPress 2.2 called plugin sandboxing which will help you deal with incompatible and bugged wordpress plugins with ease.

Plugin sandboxing will not allow plugins to activate if they break your wordpress blog or cause fatal PHP errors.

“Before a plugin is activated or a plugin is edited, it is tested in a temporary fashion (that is, without being permanently activated). If it passes the test, it is activated for real. If it doesn�t pass the test (it�s throwing a fatal error that would normally take down your WordPress install), it is deactivated, and you get a nice error message telling you what went wrong. If the fatal error was caused because you edited an active plugin, the �Update File� button changes to �Update File and Attempt to Reactivate,� so that once you correct your typo, the plugin will go back to being activated, without requiring you to go back and manually activate it.”

Most wordpress users might never know that the Plugin Sandboxing feature exists, till your bugged wordpress plugin decides to reveal this much needed functionality which could keep your wordpress running… Install plugins without fear!

Leave a Reply

Your email address will not be published. Required fields are marked *

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>