(+84) 463.28.7979

WordPress 2.1 Will Require MySQL 4.0 Database


WordPress 2.1 RC1 is already available for WordPress testers and discussion is on about which MySQL should future versions of WordPress support. It has been debated if they should drop MySQL 3.23.23 support for WordPress, and a finally a roadmap consensus has been reached.

“The WordPress 2.0.x branch will continue to support 3.23.23 for the foreseeable future, and WordPress 2.1 will require MySQL 4.0. Many people, especially plugin developers, wanted WordPress 2.1 to require MySQL 4.1. There are still a number of hosts running 4.0, however, so we decided to postpone bumping to 4.1 until WordPress 2.2 comes out. Hopefully this will give everyone sufficient notice to upgrade their installations.”

The WordPress requirements page is already displaying that WordPress requires PHP version 4.2 or greater and MySQL version 4.0 or greater. MySQL AB has already discontinued support for MySQL 4.0 since September 2006. It seems WordPress 2.2 will require MySQL version 4.1. WordPress Plugin authors have already been advised to update their plugins to support WordPress 2.1.

MySQL is the world’s most popular open source database and MySQL5 is the current recommended release. I was happy to learn that my Dreamhost webhosting is running MySQL 5. I am sure those running older versions of MySQL will now be forced to upgrade databases to support newer versions of WordPress.

While you await final release of WordPress 2.1, it is recommended you upgrade to WordPress 2.0.7 that fixes PHP security and Feedburner bugs issues.

Leave a Reply

Your email address will not be published. Required fields are marked *

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>